News A server update was released on July 20. Server patch notes and downloads are here. Additionally, a client update was released on the same day. Client patch notes are here.
This topic was marked solved by its starter, on April 21st, 06:49 PM
Problem with rulk's bot

Cool

  • Hero Member
  • Posts: 711
Problem with rulk's bot
«  »
The rulk's bot seems to doesn't work properly when we have a ":" in our text. As rulk's bot gets the username, text by splitting ":". So when I try to send any text from echo bot containing ":" it doesnt work. so how to deal with it

sseebbyy

  • Wiki Contributor
  • Something like this: hga hga hga
  • Posts: 752

Cool

  • Hero Member
  • Posts: 711
Re: Problem with rulk's bot
« Reply #2,  »
Code: [Select]
// Find the text that was typed.
local
FindText = split( raw[ 0 ], ":" ),
text = FindText.len() > 1 ? FindText[ 1 ] : "",
prefix = text != "" ? text.slice( 0, 1 ) : "";

// Find the command that was typed.
local
Findcmd = text != "" ? split( text, " " ) : "",
cmd = Findcmd != "" ? Findcmd[ 0 ].slice( 1, Findcmd[ 0 ].len() ) : "";


Doom_Kill3R

  • Wiki Contributor
  • Mess with the best, die like the rest.
  • Posts: 968
Re: Problem with rulk's bot
« Reply #3,  »
You can't deal with it. Its how its taking out event IDs and separating the raw data. It does not affect your server or the echo in any way if someone sends a : D face and there's no : in echo. So just leave it.

Cool

  • Hero Member
  • Posts: 711

Anik

  • Sr. Member
  • Posts: 349

Cool

  • Hero Member
  • Posts: 711
Re: Problem with rulk's bot
« Reply #6,  »
Problem Solved. but actually not solved i just changed the sign still cant use : :P