Vice City: Multiplayer

News & Announcements => Server & Plugin Updates => Topic started by: Stormeus on July 9th, 2018, 06:38 AM

Title: Plugin Update Released (2018-07-09)
Post by: Stormeus on July 9th, 2018, 06:38 AM
An updated plugin pack for 04rel006 servers can be found here:
https://v04.vc-mp.org/allplugins_04rel006_patch2.7z
Title: Re: Plugin Update Released (2018-07-09)
Post by: Sir. Cucuruchito on July 9th, 2018, 07:16 AM
(https://media.giphy.com/media/Nx0rz3jtxtEre/giphy.gif)
Title: Re: Plugin Update Released (2018-07-09)
Post by: VK.Angel.OfDeath on July 9th, 2018, 08:33 AM
Nice update, I am however getting this error from the console: 'plugins/squirrel04rel32.dll' plugin is for incompatible API version 0.0 (current is 2.0). I have the latest server.exe from 2018-06-28 and downloaded the plugin pack you linked.
Title: Re: Plugin Update Released (2018-07-09)
Post by: MEGAMIND on July 9th, 2018, 08:42 AM
there is still one error which says incompatible api for squirrel plugin
Title: Re: Plugin Update Released (2018-07-09)
Post by: Stormeus on July 9th, 2018, 08:59 AM
Quote from MEGAMIND on July 9th, 2018, 08:42 AM
there is still one error which says incompatible api for squirrel plugin
Quote from VK.Angel.OfDeath on July 9th, 2018, 08:33 AM
Nice update, I am however getting this error from the console: 'plugins/squirrel04rel32.dll' plugin is for incompatible API version 0.0 (current is 2.0). I have the latest server.exe from 2018-06-28 and downloaded the plugin pack you linked.
Fixed. Looks like this only affected Windows builds.
Title: Re: Plugin Update Released (2018-07-09)
Post by: [SK]Kelvin on August 6th, 2018, 04:59 AM
Sorry for bumping.
Quote from Stormeus on July 9th, 2018, 06:38 AM
An updated plugin pack for 04rel006 servers can be found here:
https://v04.vc-mp.org/allplugins_04rel006_patch2.7z
This error happens when I start my Linux server, any solution?

Code: [Select]
Vice City Multiplayer Server

-------------------------------

v0.4, (c) 2007-2014 VC:MP Team



Loaded plugin: announce04rel32



Loaded plugin: geoip04rel32



Plugin error >> dlopen() 'plugins/hashing04rel32.so' failed: /usr/lib32/libstdc++.so.6: version `CXXABI_1.3.9' not found (required by plugins/hashing04rel32.so)

Failed to load plugin: hashing04rel32



Loaded plugin: ini04rel32



Loaded plugin: mysql04rel32



Plugin error >> dlopen() 'plugins/sockets04rel32.so' failed: /usr/lib32/libstdc++.so.6: version `GLIBCXX_3.4.21' not found (required by plugins/sockets04rel32.so)

Failed to load plugin: sockets04rel32



Loaded plugin: sqlite04rel32



Plugin error >> dlopen() 'plugins/squirrel04rel32.so' failed: /usr/lib32/libstdc++.so.6: version `GLIBCXX_3.4.21' not found (required by plugins/squirrel04rel32.so)

Failed to load plugin: squirrel04rel32



Plugin error >> dlopen() 'plugins/xmlconf04rel32.so' failed: /usr/lib32/libstdc++.so.6: version `CXXABI_1.3.9' not found (required by plugins/xmlconf04rel32.so)

Failed to load plugin: xmlconf04rel32



[WEAPONS] No custom weapons to load.

[VEHICLEMODELS] No custom vehicle models to load.

** Started VC:MP 0.4 Server **

Port: 5192

Max players: 48



[0;32m[MODULE] Loaded GeoIP for 0.4 by Crys.

>> Loaded GeoIP.dat (GeoIP Country Edition)



[0;32m[MODULE] Loaded [deprecated] sq_ini for VC:MP by Stormeus.



[0;32m[MODULE] Loaded SQLite3 for VC:MP by Stormeus.
Title: Re: Plugin Update Released (2018-07-09)
Post by: Stormeus on August 10th, 2018, 03:49 AM
What Linux distribution are you running on?
Title: Re: Plugin Update Released (2018-07-09)
Post by: [SK]Kelvin on August 11th, 2018, 09:04 AM
Quote from Stormeus on August 10th, 2018, 03:49 AM
What Linux distribution are you running on?
I have no idea; since the host I'm using is not mine...
Title: Re: Plugin Update Released (2018-07-09)
Post by: Shadow on August 11th, 2018, 01:41 PM
uname -a
Title: Re: Plugin Update Released (2018-07-09)
Post by: Hendrix on August 14th, 2018, 09:17 PM
Quote from Stormeus on August 10th, 2018, 03:49 AM
What Linux distribution are you running on?
He used debian 8 the host in mine
Title: Re: Plugin Update Released (2018-07-09)
Post by: Yidals on August 18th, 2018, 09:44 AM
Code: [Select]
[[email protected] ~]# uname -a
Linux server 2.6.32-042stab120.19 #1 SMP Mon Feb 20 20:05:53 MSK 2017 x86_64 x86_64 x86_64 GNU/Linux
(centos 7)

same problem as =TRC=Kelvin

BUMP
Title: Re: Plugin Update Released (2018-07-09)
Post by: Vatan on September 10th, 2018, 11:57 AM
Nice update.
Title: Re: Plugin Update Released (2018-07-09)
Post by: Shadow on September 10th, 2018, 03:56 PM
I just searched for your problem on google @Yidals @Hendrix @=TRC=Kelvin  and this came up: https://github.com/Microsoft/napajs/issues/93#issuecomment-338504478

http://bfy.tw/JoPb
Title: Re: Plugin Update Released (2018-07-09)
Post by: Hendrix on February 11th, 2019, 01:08 AM
Quote from Shadow on September 10th, 2018, 03:56 PM
I just searched for your problem on google @Yidals @Hendrix @=TRC=Kelvin  and this came up: https://github.com/Microsoft/napajs/issues/93#issuecomment-338504478

http://bfy.tw/JoPb
Debian 8
Title: Re: Plugin Update Released (2018-07-09)
Post by: Hendrix on February 11th, 2019, 01:09 AM
Quote from Shadow on September 10th, 2018, 03:56 PM
I just searched for your problem on google @Yidals @Hendrix @=TRC=Kelvin  and this came up: https://github.com/Microsoft/napajs/issues/93#issuecomment-338504478

http://bfy.tw/JoPb
Plugin error >> dlopen() 'plugins/xmlconf04rel32.so' failed: /usr/lib32/libstdc++.so.6: version `CXXABI_1.3.9' not found (required by plugins/xmlconf04rel32.so)

Failed to load plugin: xmlconf04rel32



Loaded plugin: announce04rel32



Loaded plugin: geoip04rel32



Plugin error >> dlopen() 'plugins/squirrel04rel32.so' failed: /usr/lib32/libstdc++.so.6: version `GLIBCXX_3.4.21' not found (required by plugins/squirrel04rel32.so)

Failed to load plugin: squirrel04rel32



Loaded plugin: sqlite04rel32



Plugin error >> dlopen() 'plugins/sockets04rel32.so' failed: /usr/lib32/libstdc++.so.6: version `GLIBCXX_3.4.21' not found (required by plugins/sockets04rel32.so)

Failed to load plugin: sockets04rel32



Loaded plugin: ini04rel32



Plugin error >> dlopen() 'plugins/hashing04rel32.so' failed: /usr/lib32/libstdc++.so.6: version `CXXABI_1.3.9' not found (required by plugins/hashing04rel32.so)

Failed to load plugin: hashing04rel32



Loaded plugin: mysql04rel32



** Started VC:MP 0.4 Server **

Port: 8191

Max players: 100



[0;32m[MODULE] Loaded GeoIP for 0.4 by Crys.

>> Loaded GeoIP.dat (GeoIP Country Edition)



[0;32m[MODULE] Loaded SQLite3 for VC:MP by Stormeus.



[0;32m[MODULE] Loaded [deprecated] sq_ini for VC:MP by Stormeus.