This topic was marked solved by its starter, on March 7th, 2017, 09:56 AM
Query not working
[Client] GuiButton Crashed  »

Cool

  • Hero Member
  • Posts: 719
Query not working
« on March 7th, 2017, 06:18 AM »
Code: [Select]
else if ( cmd == "spawnwepdel")
    {

    if ( CheckTableSpawnwep( player ) )
    {
        mysql_query( sDB, "DELETE FROM SpawnWep WHERE lower(Nick)='" + player.Name.tolower() + "'" );
print(mysql_error(sDB));
        ClientMessage( "-> Your Spawnwep have been deleted.",player,255,0,102); SpawnwepPlayer[ player.ID ] = null;
    }
    else ClientMessage( "-> Error: You not have spawnwep.",player,255,0,102);
    }
error: Table 'database.SpawnWep' Does not exists

Thijn

  • VC:MP Beta Tester
  • Posts: 1,689
Re: Query not working
« Reply #1, on March 7th, 2017, 07:46 AM »
And what do you think that error means?

KAKAN

  • Wiki Contributor
  • Posts: 3,346
Re: Query not working
« Reply #2, on March 7th, 2017, 08:14 AM »
Steps to correct:
1. Open your MySQL database using phpMyAdmin
2. Check whether the table is 'Spawnwep' or 'Spawnweps'
You can contact me using Discord, at Developers.CPP( check off-board to find the invite link )
Github: https://github.com/theKAKAN

Cool

  • Hero Member
  • Posts: 719

Xmair

  • Wiki Contributor
  • Posts: 879
VU Full Member | VCCNR Developer | KTB Developer | EAD Ex-Scripter

Cool

  • Hero Member
  • Posts: 719
Re: Query not working
« Reply #6, on March 7th, 2017, 09:56 AM »
:P I did not notice this small mistake Thanks for pointing out