This topic was marked solved by its starter, on April 21st, 2017, 06:49 PM
Problem with rulk's bot

Cool

  • Hero Member
  • Posts: 719
Problem with rulk's bot
« on April 21st, 2017, 04:36 PM »
The rulk's bot seems to doesn't work properly when we have a ":" in our text. As rulk's bot gets the username, text by splitting ":". So when I try to send any text from echo bot containing ":" it doesnt work. so how to deal with it

Sebastian

  • VC:MP Beta Tester
  • Something like this: hga hga hga
  • Posts: 906
Re: Problem with rulk's bot
« Reply #1, on April 21st, 2017, 04:44 PM »
How does exactly look the code of rulk for onPlayerText ?

Cool

  • Hero Member
  • Posts: 719
Re: Problem with rulk's bot
« Reply #2, on April 21st, 2017, 04:58 PM »
Code: [Select]
// Find the text that was typed.
local
FindText = split( raw[ 0 ], ":" ),
text = FindText.len() > 1 ? FindText[ 1 ] : "",
prefix = text != "" ? text.slice( 0, 1 ) : "";

// Find the command that was typed.
local
Findcmd = text != "" ? split( text, " " ) : "",
cmd = Findcmd != "" ? Findcmd[ 0 ].slice( 1, Findcmd[ 0 ].len() ) : "";


Doom_Kill3R

  • VC:MP Beta Tester
  • Infinite loops defy infinity by overflowing memory
  • Posts: 1,099
Re: Problem with rulk's bot
« Reply #3, on April 21st, 2017, 05:18 PM »
You can't deal with it. Its how its taking out event IDs and separating the raw data. It does not affect your server or the echo in any way if someone sends a : D face and there's no : in echo. So just leave it.

Cool

  • Hero Member
  • Posts: 719

Anik

  • Sr. Member
  • Posts: 355

Cool

  • Hero Member
  • Posts: 719
Re: Problem with rulk's bot
« Reply #6, on April 21st, 2017, 06:49 PM »
Problem Solved. but actually not solved i just changed the sign still cant use : :P