« [Bug] Chat Desync
Other GUILabel problem.

Athanatos

  • Hero Member
  • Romania Cops N Robbers Lead Developer
  • Posts: 810
Other GUILabel problem.
«  »Last edited
Description
The second GUILabel I created does not show up.
Code: [Select]

        ::hplabel <- GUILabel(VectorScreen(sX * 0.7,10),Colour(255,255,255),"not working :c");
::hplabel.FontSize = 15;
::hplabel2 <- GUILabel(VectorScreen(sX * 0.7,10),Colour(255,255,255),"Health");
::hplabel2.FontSize = 15;
Proof:
(click to show/hide)

Reproducible
Sometimes.Depends on the text of the label?

What you were doing when the bug happened

Scripting.

What you think caused the bug
I dunno.

kennedyarz

  • Sr. Member
  • Making American Great Again
  • Posts: 334
Re: Other GUILabel problem.
« Reply #1,  »
it seems strange to you, but it has to do with the size of the label

change 15 for 12

Code: [Select]
::hplabel2.FontSize = 12;

and see how it works. I think that was the problem. I can not verify since I'm away from home with my phone

Athanatos

  • Hero Member
  • Romania Cops N Robbers Lead Developer
  • Posts: 810
Re: Other GUILabel problem.
« Reply #2,  »
Quote from kennedyarz on June 29th, 2018, 04:26 PM
it seems strange to you, but it has to do with the size of the label

change 15 for 12

Code: [Select]
::hplabel2.FontSize = 12;

and see how it works. I think that was the problem. I can not verify since I'm away from home with my phone
Thank you! Solved.

Stormeus

  • VC:MP Developer
  • oh god how did i get here im not good w computer
  • Posts: 1,128
Re: Other GUILabel problem.
« Reply #3,  »
Un-marking this as solved since GUILabels shouldn't disappear when they're set to a larger font size.

kennedyarz

  • Sr. Member
  • Making American Great Again
  • Posts: 334
Re: Other GUILabel problem.
« Reply #4,  »
Quote from Stormeus on June 29th, 2018, 05:02 PM
Un-marking this as solved since GUILabels shouldn't disappear when they're set to a larger font size.
that's very old just always forget to post
but I remember that I gave that data to a beta tester. the problem is that I do not remember which of them

NewK

  • VC:MP Beta Tester
  • Posts: 176
Re: Other GUILabel problem.
« Reply #5,  »
Reviving this topic to inform anyone having this issue, use the empty GUILabel() constructor instead of using the  GUILabel(position,colour,text) constructor and you won't have this issue. However that constructor does have other issues though, such as the flags GUI_FLAG_WRAP and GUI_FLAG CLIP not working.