OkieDokie

  • Newbie
  • I Like Weed
  • Posts: 17
Squirrel/sqmod error someone please help.
«  »Last edited
i have ran into a problem, only error, and it is crashing the script on player join ?

[ERR] An error occured [ the index 'Language' does not exist ][/][/err]
[ERR][ the index 'Language' does not exist ]
at origin: /home/vlmp/scripts/Miscs/Message.nut: 103, function: unknown
[ERR] [Locals]  [type]: [#03a9f4]
        [element]: (array : 0x0x189f930)
        [vargv]: (array : 0x0x884d890)
        [player]: 1
        [st]: (array : 0x0x884df60)     Any suggestions ? this has been driving me crazy, i used to script in squirrel alot, but was away for a year, i recently came back, and this sqmod is new to me, but yeah. so i am helping for free, and am the new developer. so if anyone that could help me on this one single error left please and thank you..
Viceland Dev

umar4911

  • Sr. Member
  • Creating own server!
  • Posts: 472
I am gamer, programmer and hacker. Try to find me!
xD

OkieDokie

  • Newbie
  • I Like Weed
  • Posts: 17
Re: Squirrel/sqmod error someone please help.
« Reply #2,  »
Yes well, where do i exactly place these variable codes in that link you sent me, i've checked the .nut script and i dont see any code written for variables, so im not sure where to place, do you have discord ? maybe i could screen share ? more help would be appreciated thanks ! :)
Re: Squirrel/sqmod error someone please help.
« Reply #3,  »
Abit more detailed help would be alittle appreciated, i understand the error, i just need to refresh my memory its been awhile, and im not exactly sure where to add these codes in the script ?
Viceland Dev

umar4911

  • Sr. Member
  • Creating own server!
  • Posts: 472
Re: Squirrel/sqmod error someone please help.
« Reply #4,  »
Quote from OkieDokie on May 15th, 03:52 PM
Yes well, where do i exactly place these variable codes in that link you sent me, i've checked the .nut script and i dont see any code written for variables, so im not sure where to place, do you have discord ? maybe i could screen share ? more help would be appreciated thanks ! :)
You called variable Language at line 103 but the variable doesn't exist
I am gamer, programmer and hacker. Try to find me!
xD

=RK=MarineForce

  • Sr. Member
  • WAR IS HELL!
  • Posts: 447
Try to UnderStand ME!

OkieDokie

  • Newbie
  • I Like Weed
  • Posts: 17
Re: Squirrel/sqmod error someone please help.
« Reply #6,  »
ok so umar, in the entire script of Message.nut i many lines with player.data.language,

but the only error displaying is for line 103, so do i just remove all lines in the .nut file and change to player.data.variable ?

 you mean
Viceland Dev

umar4911

  • Sr. Member
  • Creating own server!
  • Posts: 472
I am gamer, programmer and hacker. Try to find me!
xD

OkieDokie

  • Newbie
  • I Like Weed
  • Posts: 17
Re: Squirrel/sqmod error someone please help.
« Reply #8,  »
do you mean the .nut file of playerjoin or you talking about the errorcode in the server console when a player connects and crashes scripts

That would be this one



at origin: /home/vlmp/scripts/Miscs/Message.nut: 103, function: unknown
[ERR] [Locals]  [type]: [#03a9f4]
        [element]: (array : 0x0x2584b30)
        [vargv]: (array : 0x0x95a3990)
        [player]: 0
        [st]: (array : 0x0x95a3f80)

[ERR] An error occured [ the index 'language' does not exist ]
at origin: /home/vlmp/scripts/Miscs/Message.nut: 103, function: unknown
[ERR] [Locals]  [type]: [#03a9f4]
        [element]: (array : 0x0x2584b30)
        [vargv]: (array : 0x0x95a4120)
        [player]: 0
        [st]: (array : 0x0x95a47c0)

[ERR] An error occured [ the index 'language' does not exist ]
at origin: /home/vlmp/scripts/Miscs/Message.nut: 103, function: unknown
[ERR] [Locals]  [type]: [#03a9f4]
        [element]: (array : 0x0x2584b30)
        [vargv]: (array : 0x0x95a4830)
        [player]: 0
        [st]: (array : 0x0x95a4090)


Re: Squirrel/sqmod error someone please help.
« Reply #9,  »
i've tried even removing language from the lines, ive tried like all kinds of shit, the scripts still load, but crash when someone connects.
Re: Squirrel/sqmod error someone please help.
« Reply #10,  »
than more errors appear in the scripts/events/player folders for those .nut script files. -.- ugh so is it possible to just fix this error and not have anymore pop up, the script loads, everything seems to be working, just crashes on player join, and we can talk in server, basically with no scripts and shit loaded at all.
Viceland Dev

dracc

  • Jr. Member
  • Posts: 84
Re: Squirrel/sqmod error someone please help.
« Reply #13,  »
Please don't bump your threads like a madman?

Make sure you're capitalizing your variable names correctly ("Langauge" is not the same as "language").

OkieDokie

  • Newbie
  • I Like Weed
  • Posts: 17
Re: Squirrel/sqmod error someone please help.
« Reply #14,  »
ok so, does this mean im gonna have to change everyline like that, cause only error is in line 103 ?

but theres multiple lines written with that index
Viceland Dev