This topic was marked solved by its starter, on June 25th, 2019, 10:15 PM
Client doesnt respond after first connect to server

Eva

  • Full Member
  • Posts: 167
Client doesnt respond after first connect to server
«  »
Everytime i start vcmp client the first time i want to connect to a server the client doesnt respond.
Then when i restart the client second time it does.
Reproducable: always.
Does anyone know why? and how to solve it?
My os is Win7 Ultimate 64bit

.

  • VC:MP Beta Tester
  • .
  • Posts: 1,807
Re: Client doesnt respond after first connect to server
« Reply #1,  »
If you use something like Process Explorer you will notice that bellow your `vice.exe` process (if you've configured Process Explorer to group parent/child processes) there's something like `gameux.dll`.

That `gameux.dll` is basically windows game explorer that's part of windows 7 and it tries to attach to your game to (likely) provide some in-game user interface and also to retrieve information about the game from the internet. That second task it does (connecting to the internet) it fails. Actually it doesn't happen so it hangs your game while trying.

This feature of windows cannot be removed (thank MICROSH!T for that) and it happens to more games than just Vice City. All you can probably do is to make windows game explorer forget about your games. IIRC, you can do that by removing some registry entries.

Just look up (i.e. google) how to prevent windows game explorer (or `gameux.dll`) from attaching and hanging your game.
.

rww

  • VC:MP Beta Tester
  • LU-DM Team
  • Posts: 400

Join to LU-DM Team Discord: https://discord.gg/PFwem6J