Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.

Topics - Fjose
1
Scripting and Server Management / Pickups cannot be picked
« on May 25th, 2015, 04:40 PM »
I can't take the weapons from the pickups, I'm not seeing any problems on the script.

Code: [Select]
        CreatePickup( 280, Vector( -1744.31, -299.216, 14.8683 ) ); // m4 group
CreatePickup( 274, Vector( -1741.35, -294.67, 14.8683 ) ); // col group
CreatePickup( 274, Vector( -1691.8, -177.954, 14.8683 ) );
CreatePickup( 289, Vector( -1663.16, -129.052, 14.8683 ) ); // m6 group


function onPickupPickedUp( player, pickup )
{
local model = pickup.Model, id = player.ID, p = pinfo[id];
switch( model )
{
case 274:
return player.SetWeapon( 274, 50 );
break;
case 280:
return player.SetWeapon( 280, 60 );
break;
case 289:
return player.SetWeapon( 289, 40 );
break;
case 408:
return gMessage( id, mGreen, "Your Financial Status - Cash: $" + Bytes( p.Cash ) + ", Bank: $" + Bytes( p.Bank ) );
default:
break;
}
pickup.RespawnTime = 5;
}
2
General Discussion / [DOUBT] About vehicles
« on May 25th, 2015, 12:56 AM »
Someone know why always when the vehicle is created, it's positioned to the North and not the correct rotation.
3
Since that I've changed my windows from 7 to 8.1, I had some problems with the net card while i'm navigating, for example: Each x time my connection is down and for solve the problem, I have to turn off my laptop because if I try use the solver of problems of windows, my laptop got a crash and it freezes and then I have to remove the battery as unique form. Curiously this only happens when I use the browsers, because if I'm playing vcmp, that does not happens and same if I'm downloading something (for example with the Windows Update or DriverEasy nothing happens), but the connection fails if I'm downloading using the browser. I tried other solutions but without results. Would be two problems:

1) Repair the connection problems with the card.
2) Repair the crash when I use the solver of problems (only occurs when I use it with this card).



Note: I've already tried downloading the drivers from HP Page without results (with those drivers I can't use the wifi)
4
Support / I can't join a server on Windows 8.1
« on May 5th, 2015, 04:53 PM »
I have windows 8.1 Enterprise x64. I can play without problems the gta vc but in the multiplayer when I'm trying to join, client says: could not start process. I had to download the msvcr120 and msvcp120 for the two versions (x64 and x32) and problem still exist. Someone can help me?

5
In this case, I was importing the vehicles from my 0.3 server to 0.4, all those coordinates are located in the 'server.conf', In the next code everything looks good but for any reason the angle is not taken how must be. it's like if the server is ignoring this part.  In the principle I was thinking it the problem was caused by use negative values in the 'x coordinate', but after see sk's post, I realized it the problem was with the angle how he said.

Code: [Select]
<Vehicle model="224" world="1" x="-842.2524" y="-909.7036" z="10.8677" angle="356.8192" col1="0" col2="0"/>
<Vehicle model="224" world="1" x="-896.0913" y="-999.1013" z="13.9701" angle="187.0791" col1="0" col2="0"/>

6
Scripting and Server Management / GetWeaponAtSlot a substitute?
« on January 29th, 2015, 01:28 AM »
'GetWeaponAtSlot' since this function does not exist or maybe have other name, I'll would like know the correct name for this function, if this was added and how use it.
7
Scripting and Server Management / [doubt] onObjectShot and onObjectBump
« on January 26th, 2015, 02:40 AM »
how i can use these functions? ???
I was trying with a simple line to see if happens something and nothing :-\
Quote
test_object  <- CreateObject( 343, 1, -896.9, -338.783, 13.382, 255 );

function onObjectShot( object, player, weapon )
{
   if ( object == test_object ) { CreateExplosion( 1, 4, Vector( -896.9, -338.783, 13.382 ), -1, true ); Message( "aa" ); }
}

function onObjectBump( o, p )
{
   if ( object == test_object ) { CreateExplosion( 1, 4, Vector( -896.9, -338.783, 13.382 ), -1, true ); Message( "aa" ); }
}
8
General Discussion / Add GetObjectCount()
« on January 19th, 2015, 11:45 PM »
:'(
9
Scripting and Server Management / [doubt] xml functions
« on January 17th, 2015, 05:00 PM »
who knows the current xml functions? I was thinking it was the same like LU
10
Scripting and Server Management / [doubt] how get the object angle?
« on January 13th, 2015, 02:51 PM »
I was trying to use objectid.Angle but the server says member variable not found. the other is how get the 'w' (rotation) for the Quaternion function..
11
Scripting and Server Management / Announce problem
« on December 24th, 2014, 08:10 PM »
current sintaxis is Announce( playerTo, message, type ), for e.gg I have: Announce( player, "Hello everybody", 5 ); and nothing happens but if I have Announce( "Hello everybody", 5 ); the message appears, I guess it Announce function have a problem with the player variable, I've tried 'player.ID' and 'player' and nothing.
12
Scripting and Server Management / [DOUBT] It is possible add custom sounds
« on December 20th, 2014, 08:25 PM »
custom sounds for players.

note: I'm not talking about the vehicle radio.
13
Scripting and Server Management / KickPlayer problem
« on December 11th, 2014, 02:57 AM »
Kicking player and nothing happens, incredibly this code was working perfectly on 0.3z version

Code: [Select]
function KickPlr( id )
{
local player = FindPlayer( id );
if ( player )
{
if ( pinfo[id].Logged == true ) SavePlayerData( id );
pinfo[id] = null;
local blah = collectgarbage();
print( blah );
players.rawdelete(id );
KickPlayer( player );
}
}



14
Scripting and Server Management / Player Marker
« on December 1st, 2014, 01:53 AM »
I was seeing some functions but I can't find a function for hide players only with a different skin. player can see others with same skin but not with a different skin, that's my idea.

15
Scripting and Server Management / sprite.HideForPlayer problem
« on November 25th, 2014, 07:08 PM »
the problem is simple.
I have created a sprite and this is loaded in onScriptLoad(), when I use "any_sprite.ShowForPlayer( player )" in onPlayerDeath works fine, when player dies, this will be auto respawned but the server shows an error in the line.

any_sprite.HideForPlayer( player ). the error in the console is: "player" variable doesn't exists but exists...