« [BUG?] Window
[Bug] Rel006 Streaming issue?

VK.Angel.OfDeath

  • Newbie
  • Posts: 13
[Bug] Rel006 Streaming issue?
«  »Last edited
Subject: [Bug] Rel006 rare streaming issue?



Description
Ok this is a really weird one that I can't seem to understand. Please watch this video to get a closer look at the issue I am facing.

Note: For some reason when I play the video from the forum, the quality even though it appears to be in 1080p is bad. If this happens to you, try to set the quality from automatic to 1080p and/or play it directly from youtube. The text should be viewable in the best quality setting.


https://www.youtube.com/watch?v=oFCiw1g_xds

So basically what the video shows is me and the two other players entering property 281 on the rel006 version of VKs official server (not available to public yet). The bug is that when one of us enters into a vehicle  everything around us like objects, vehicles, pickups and even players disappear. In the video I showed it from two perspectives (when I entered a vehicle) and when I watched a player enter a vehicle. When I watched a player enter the vehicle I saw them disappear together with the vehicle and their minimap marker started to freak out, teleporting randomly across the map.

Here are a few details that may or may not be relevant:
- Property 281 is located in world 480 and contains a couple of objects, pickups and vehicles that are created when one person enters the world and deleted when the last player leaves the world.
- I did not manage to replicate the bug in other properties. So it is possible that it is a scripting bug caused by my system but I have never seen players being in the same world and still not being streamed to each other. I definitely haven't messed around with that on purpose at least. Which makes me think it might be a very small bug in the source code that is not easy to trigger. In addition I can't seem to trigger this bug on a rel003.
- In the video I did /world to confirm that all players were still in the same world after and before someone entered a vehicle
- In the video you see this only happening to custom vehicles, but I can confirm it happens to normal vehicles that are brought to the world as well, even those created when the server starts.
- I noticed that an object of model 12 or 13 (which doesn't exist) is created in the property (from a /showdebug message in the vide). I tried to create the same model in other properties as well, but it did not trigger this bug.
- As you can see in the video the bug was not triggered when one player entered a vehicle during the recording, but the bug has been triggered for all three of us at least a few times before.
- I use no mods and I have an original copy of GTA VC.
- I tested it on rel003 as well it doesn't happen on that version.

If this bug is hard to find for the devs I can try  to re-create the property in another world to find out what exactly is causing it. But I just wanted to get this report out there to see if you any of you can figure out what's causing it.

Reproducible
Yes it's reproducible but the thing is it's only reproducible under a very specific condition that I can't figure out. Check the description to see what I tested.

What you were doing when the bug happened
It can be seen in video and is described in the description.


What you think caused the bug
I have no idea. Maybe a model + color fails to load and all the other entities that are streamed disappear as well? I am mostly hoping that the devs will be able to spot the bug, if not then I will try to conduct more tests to figure out exactly what's causing it.

Stormeus

  • VC:MP Developer
  • oh god how did i get here im not good w computer
  • Posts: 1,044
[Bug] Re: Rel006 Streaming issue?
« Reply #1,  »
Is there any info in %APPDATA%\VCMPbeta\debuglog.txt when you do this? Note that this file is emptied every time you join a server.

Can you also try this with /showdebug 1 and post logs?

VK.Angel.OfDeath

  • Newbie
  • Posts: 13
[Bug] Re: Rel006 Streaming issue?
« Reply #2,  »Last edited
Quote from Stormeus on July 14th, 05:18 PM
Is there any info in %APPDATA%\VCMPbeta\debuglog.txt when you do this? Note that this file is emptied every time you join a server.

Can you also try this with /showdebug 1 and post logs?
I already did showdebug in the video. But since you asked re-did the testing and got this:

Code: [Select]
[18:33:56]  Connecting to 192.168.1.168:5193..
[18:33:56]  Connection success. Loading server info...
[18:34:02]  Connection: Connection established
[18:34:02]  Information: VK.Angel.OfDeath joined the server.
[18:34:02]  Welcome to the server, VK.Angel.OfDeath!
[18:34:02]  This is VK's Official server version 4.4.1 scripted by VK.Angel.OfDeath and created by VK.Angel.OfDeath & EK.CrystalBlue. Beta tested by Qais99 & Thunderhead. For full credits type /credit.
[18:34:02]  VK.Angel.OfDeath automatically logged in to the server.
[18:34:02]  Information: Name: VK.Angel.OfDeath. Level: 24 (Administrator).
[18:34:02]  Information: Remember to use /info, /help and /news to get the best possible experience. You can disable autologin with /setautologin off.
[18:34:02]  Information: Type /spectate or use F12 to start spectating someone. Disable spectate with /spectatemode off.
[18:34:02]  News: Patch 4.4.1 has been released. Check the forum or type /news.
[18:34:02]  Warning: Your account has: 5 permanent warnings. Too many warnings can lead to a ban.
[18:34:02]  Information: Qais99 joined the server.
[18:34:02]  Qais99 automatically logged in to the server.
[18:34:10]  Information: VK.Vampire joined the server.
[18:34:10]  VK.Vampire automatically logged in to the server.
[18:34:11]  Information: Spawn protection enabled.
[18:34:12]  Major Qais99: i'm here
[18:34:13]  Command: You're being teleported to the property: 281. Use /prop if you forget which property you're in.
[18:34:17]  Command: You have automatically received the weapons: Destroyer, Santa Hat.
[18:34:17]  Information: Use /exitcustomprop to return to the normal world.
[18:34:17]  Information: Spawn protection disabled.
[18:34:18]  Information:  ID: 281. Name: Nsk official World. Owner: =NsK=Halo^. Shared Owners: SdS.Neptune^ (4), =FS=Rider^ (1), [FS]Aphrodi^ (4), [FS]Champion (2), =EK=AsIyaN^ (4), [UFr]Shadow.JacK^ (4), Batch^47 (1), =LPt=Floorina^ (2), [FS]Infernape(A) (1), =NsKr=[U]z[I] (4), Rainbow_Dash (4), NsK.Supe[R]Saiya[N] (4), [ON]HunTinG (1).
[18:34:20]  Cop VK.Angel.OfDeath: Prop 281
[18:34:32]  Major Qais99: enter?
[18:34:32]  Information: Property 281 vehicle - Vehicle Index: 4. Vehicle Name: Autarch. Vehicle Model: 6424. Vehicle Health: 1000. Owner: =NsK=Halo^. Shared Owners: None & None.
[18:34:35] 
[18:34:35]  Event: The treasure hunting event's from 2012-2017 have been turned into /treasurehunter. Experience 5 years of events in that job.
[18:34:35] 
[18:34:46]  [STREAMING] Lost ownership of vehicle 274.
[18:34:46]  Major Qais99: I got disappear
[18:34:50]  Command: You will exit the custom property in 3 seconds.
[18:34:51]  [STREAMING] Vehicle 271 spawned.
[18:34:52]  [STREAMING] Player 'Qais99' spawned.
[18:34:53]  [STREAMING] Vehicle 271 destroyed.
[18:34:53]  [STREAMING] Vehicle 273 destroyed.
[18:34:53]  [STREAMING] Vehicle 76 spawned.
[18:34:53]  [STREAMING] Vehicle 215 spawned.
[18:34:53]  [STREAMING] Vehicle 77 spawned.
[18:34:53]  [STREAMING] Vehicle 247 spawned.
[18:34:53]  [STREAMING] Vehicle 174 spawned.
[18:34:53]  [STREAMING] Vehicle 173 spawned.
[18:34:53]  [STREAMING] Vehicle 175 spawned.
[18:34:53]  [STREAMING] Vehicle 168 spawned.
[18:34:53]  [STREAMING] Vehicle 258 spawned.
[18:34:53]  [STREAMING] Vehicle 151 spawned.
[18:34:53]  [STREAMING] Vehicle 44 spawned.
[18:34:53]  Information: You've exited the custom property.

[18:34:54]  [STREAMING] Player 'Qais99' destroyed.
[18:34:54]  [STREAMING] Player 'VK.Vampire' destroyed.
[18:34:55]  [STREAMING] Vehicle 274 destroyed.

[18:34:55]  Command: You're being teleported to the property: 281. Use /prop if you forget which property you're in.

[18:34:58]  [STREAMING] Vehicle 44 destroyed.
[18:34:58]  [STREAMING] Vehicle 151 destroyed.
[18:34:58]  [STREAMING] Vehicle 258 destroyed.
[18:34:58]  [STREAMING] Vehicle 168 destroyed.
[18:34:58]  [STREAMING] Vehicle 175 destroyed.
[18:34:58]  [STREAMING] Vehicle 173 destroyed.
[18:34:58]  [STREAMING] Vehicle 174 destroyed.
[18:34:58]  [STREAMING] Vehicle 247 destroyed.
[18:34:58]  [STREAMING] Vehicle 77 destroyed.
[18:34:58]  [STREAMING] Vehicle 215 destroyed.
[18:34:58]  [STREAMING] Vehicle 76 destroyed.
[18:34:58]  [STREAMING] Vehicle 274 spawned.
[18:34:58]  [STREAMING] Vehicle 271 spawned.
[18:34:58]  [STREAMING] Player 'VK.Vampire' spawned.
[18:34:58]  [OBJECTS] Server created invalid object 12: wrong model type.
[18:34:58]  Command: You have automatically received the weapons: Destroyer, Santa Hat.
[18:34:58]  Information: Use /exitcustomprop to return to the normal world.
[18:34:58]  Information:  ID: 281. Name: Nsk official World. Owner: =NsK=Halo^. Shared Owners: SdS.Neptune^ (4), =FS=Rider^ (1), [FS]Aphrodi^ (4), [FS]Champion (2), =EK=AsIyaN^ (4), [UFr]Shadow.JacK^ (4), Batch^47 (1), =LPt=Floorina^ (2), [FS]Infernape(A) (1), =NsKr=[U]z[I] (4), Rainbow_Dash (4), NsK.Supe[R]Saiya[N] (4), [ON]HunTinG (1).

// Comment: This is where I enter the property and the bug occurs when I enter the vehicle.

[18:35:00]  [STREAMING] Vehicle 273 spawned.
[18:35:00]  VK.Vampire: I dunno why it doesn't work with me anymore
[18:35:02]  [STREAMING] Player 'Qais99' spawned.
[18:35:03]  [VEHICLE] Allowed enter: player 0, vehicle 271, dat 15, flag 1, obj 18, radio 8, rlock 0
[18:35:03]  [STREAMING] Gained ownership of vehicle 271.
[18:35:05]  Information: Property 281 vehicle - Vehicle Index: 1. Vehicle Name: Merdec. Vehicle Model: 6415. Vehicle Health: 1000. Owner: =NsK=Halo^. Shared Owners: =NsK=Vegito & None.

// Comment: Entered the vehicle here and everything is "destroyed" even though they're still supposed to be there.

[18:35:06]  [STREAMING] Vehicle 273 destroyed.
[18:35:06]  [STREAMING] Player 'Qais99' destroyed.
[18:35:06]  [STREAMING] Player 'VK.Vampire' destroyed.
[18:35:07]  [STREAMING] Vehicle 274 destroyed.
[18:35:09]  [STREAMING] Lost ownership of vehicle 271.
[18:35:10]  [STREAMING] Vehicle 274 spawned.
[18:35:10]  [STREAMING] Player 'VK.Vampire' spawned.
[18:35:10]  [OBJECTS] Server created invalid object 12: wrong model type.
[18:35:10]  [STREAMING] Gained ownership of vehicle 271.
[18:35:12]  [STREAMING] Vehicle 273 spawned.
[18:35:13]  [STREAMING] Player 'Qais99' spawned.
[18:35:13]  [STREAMING] Lost ownership of vehicle 271.
[18:35:16]  [STREAMING] Player 'Qais99' destroyed.
[18:35:17]  [STREAMING] Player 'Qais99' spawned.
[18:35:19]  [STREAMING] Player 'Qais99' destroyed.

[18:35:19]  Cop VK.Angel.OfDeath: Done

[18:35:20]  [STREAMING] Player 'Qais99' spawned.
[18:35:22]  Cop VK.Angel.OfDeath: Brb
[18:35:28]  [STREAMING] Player 'Qais99' destroyed.
[18:35:29]  [STREAMING] Vehicle 271 destroyed.
[18:35:30]  Major Qais99: ...


I added //comments to the logs to make it easier to find.

Here's that debuglog.txt file that is from exactly when I join the server (about 18.34)

Code: [Select]
MSG: Injecting phase took 0ms.
MSG: Base initialising phase took 94ms.
MSG: Blocked plugin 'vc-mp.flt', ASI mods are not allowed in VC:MP
MSG: Successfully loaded San Andreas vehicle texture dictionary.
MSG: World initialising phase took 78ms.
MSG: Net initialising phase took 62ms.
MSG: Wave file gunshot.wav - using channels 0 and 1 as left and right samples.
MSG: Loaded 4 anims from IFP file for weapon.
MSG: Successfully loaded weapon 100 from file unknown
MSG: Successfully loaded weapon 101 from file unknown
MSG: Successfully loaded weapon 102 from file unknown
MSG: Successfully loaded weapon 103 from file unknown
Warning in CMvlWeapon::LoadXMLSectionWeapon: Pickup spawn list not handled in MP.
MSG: Successfully loaded weapon 104 from file unknown
MSG: Successfully loaded weapon 105 from file unknown
MSG: Successfully loaded weapon 106 from file unknown
MSG: Successfully loaded weapon 107 from file unknown
MSG: Wave file gunshot.wav - using channel 0 for both left and right samples.
MSG: Successfully loaded weapon 108 from file unknown
MSG: Wave file gunshot.wav - using channels 0 and 1 as left and right samples.
MSG: Successfully loaded weapon 109 from file unknown
MSG: Loaded 4 anims from IFP file for weapon.
MSG: Successfully loaded weapon 110 from file unknown
MSG: Wave file gunshot.wav - using channel 0 for both left and right samples.
MSG: Successfully loaded weapon 111 from file unknown
MSG: Wave file gunshot.wav - using channel 0 for both left and right samples.
MSG: Successfully loaded weapon 112 from file unknown
MSG: Successfully loaded weapon 114 from file unknown
MSG: Successfully loaded weapon 115 from file unknown
MSG: Successfully loaded weapon 116 from file unknown
MSG: Successfully loaded weapon 117 from file unknown
MSG: Loaded 6 anims from IFP file for weapon.
MSG: Successfully loaded weapon 118 from file unknown
MSG: Successfully loaded weapon 119 from file unknown
MSG: Successfully loaded weapon 120 from file unknown
MSG: Successfully loaded weapon 121 from file unknown
MSG: Successfully loaded weapon 122 from file unknown
MSG: Successfully loaded weapon 123 from file unknown
MSG: Successfully loaded weapon 130 from file unknown
Warning in CWeaponHandler::GetNewSlotForArchive: Slot requested by file already in use, taking first free ID.
MSG: Loaded 6 anims from IFP file for weapon.
MSG: Successfully loaded weapon 113 from file unknown
Warning in CWeaponHandler::GetNewSlotForArchive: Slot requested by file already in use, taking first free ID.
MSG: Successfully loaded weapon 124 from file unknown
MSG: Successfully loaded weapon 131 from file unknown
MSG: Successfully loaded weapon 133 from file unknown
MSG: Successfully loaded weapon 134 from file unknown
MSG: Successfully loaded weapon 135 from file unknown
MSG: Successfully loaded weapon 136 from file unknown
Warning in CWeaponHandler::GetNewSlotForArchive: Slot requested by file already in use, taking first free ID.
MSG: Successfully loaded weapon 125 from file unknown
MSG: Successfully loaded weapon 138 from file unknown
MSG: Successfully loaded weapon 139 from file unknown
MSG: Successfully loaded weapon 140 from file unknown
MSG: Successfully loaded weapon 141 from file unknown
MSG: Successfully loaded weapon 142 from file unknown
MSG: Successfully loaded weapon 143 from file unknown
MSG: Wave file gunshot.wav - using channels 0 and 1 as left and right samples.
MSG: Successfully loaded weapon 144 from file unknown
MSG: Loaded 6 anims from IFP file for weapon.
MSG: Successfully loaded weapon 145 from file unknown
MSG: Loaded 6 anims from IFP file for weapon.
MSG: Successfully loaded weapon 146 from file unknown
MSG: Loaded 6 anims from IFP file for weapon.
MSG: Successfully loaded weapon 147 from file unknown
MSG: Loaded 6 anims from IFP file for weapon.
MSG: Successfully loaded weapon 148 from file unknown
Warning in CMvlWeapon::LoadXMLSectionWeapon: Pickup spawn list not handled in MP.
MSG: Loaded 6 anims from IFP file for weapon.
MSG: Successfully loaded weapon 149 from file unknown
MSG: Loaded 6 anims from IFP file for weapon.
MSG: Successfully loaded weapon 150 from file unknown
MSG: Loaded 6 anims from IFP file for weapon.
MSG: Successfully loaded weapon 151 from file unknown
MSG: ID 12000: 'Glider 102' from archive ''
MSG: ID 12001: 'Batman Car' from archive ''
MSG: ID 12002: 'Lamborghini Countach' from archive ''
MSG: ID 12003: 'Turbocharger' from archive ''
MSG: ID 12004: 'Hydra' from archive ''
MSG: ID 12005: 'UFO' from archive ''
MSG: ID 12006: 'Ferrari 360 Modena' from archive ''
Warning in CSoundHandler::FillSampleBufferFromData: More than one channel in rcengine1.wav, using only the first one.
Warning in CSoundHandler::FillSampleBufferFromData: More than one channel in rcengine2.wav, using only the first one.
MSG: ID 12007: 'Hot Air Balloon' from archive ''
MSG: ID 12008: 'Sabre Turbo' from archive ''
MSG: ID 12009: 'Dodo' from archive ''
MSG: Loaded 18 anims from IFP file for vehicle.
MSG: ID 12010: 'SB' from archive ''
MSG: ID 12011: 'Aston Martin DB9' from archive ''
MSG: ID 12012: 'Kaneda's Bike' from archive ''
MSG: ID 12013: 'Formula 1' from archive ''
MSG: ID 12014: 'Monster truck' from archive ''
MSG: ID 12015: 'Mercedes SLR' from archive ''
MSG: ID 12016: 'Monocycle' from archive ''
MSG: ID 12017: 'Dragonate' from archive ''
MSG: ID 12018: 'Avento' from archive ''
MSG: Loaded 18 anims from IFP file for vehicle.
MSG: ID 12019: 'Honda CBR-900' from archive ''
MSG: Loaded 18 anims from IFP file for vehicle.
MSG: ID 12020: 'MiniMoto' from archive ''
MSG: ID 12021: 'Rustler' from archive ''
MSG: Loaded 6 anims from IFP file for vehicle.
MSG: ID 12022: 'Vapid FMJ' from archive ''
MSG: Loaded 18 anims from IFP file for vehicle.
MSG: ID 12023: 'BF400' from archive ''
MSG: Dimensions set to 2.345218 5.106093 1.253719.
MSG: ID 12024: 'Autarch' from archive ''
MSG: Loaded 12 anims from IFP file for vehicle.
MSG: ID 12025: 'Quad Bike' from archive ''
MSG: ID 12030: 'Super GT' from archive ''
MSG: Loaded 6 anims from IFP file for vehicle.
MSG: ID 12033: 'T20' from archive ''
MSG: ID 12040: 'Cadillac Eldorado' from archive ''
MSG: ID 12041: 'Sea Maverick' from archive ''
MSG: ID 12042: 'Stang' from archive ''
MSG: ID 12043: 'MonsterB' from archive ''
MSG: ID 12045: 'Suzuki 1000RR' from archive ''
MSG: ID 12046: 'Infernus' from archive ''
MSG: Loaded 7 anims from IFP file for vehicle.
MSG: ID 12047: 'Scorpion IV' from archive ''
MSG: ID 12048: 'Gauntlet' from archive ''
MSG: ID 12049: '~x~' from archive ''
MSG: Loaded 18 anims from IFP file for vehicle.
MSG: ID 12050: 'BF400' from archive ''
Error in CVehicleHandler::LoadVehicleArchives: Could not load vehicle file 'vehicles/v6450_t1_p2_wayfarer.7z' with model index 12050 - model index already in use.
MSG: ID 5950: 'Pgb' from archive ''
MSG: ID 5951: 'Pga' from archive ''
MSG: ID 5952: 'Victor Vance' from archive ''
MSG: ID 5953: 'Avery Carrington' from archive ''
MSG: ID 5954: 'Batman' from archive ''
MSG: ID 5955: 'Ironman' from archive ''
Error in CSkinHandler::LoadSkinArchives: Could not load skin file 'skins/z205_pastor richards.7z' with model index 5955 - model index already in use.
MSG: ID 5956: 'Auntie Poulet' from archive ''
MSG: ID 5957: 'BJ Smith' from archive ''
MSG: ID 5958: 'Umberto Robina' from archive ''
MSG: ID 5959: 'Cool Guy' from archive ''
MSG: ID 5960: 'James Earl Cash' from archive ''
MSG: ID 5961: 'WMOBU' from archive ''
MSG: ID 5962: 'Ironman' from archive ''
MSG: ID 5963: 'SonicBoom' from archive ''
MSG: ID 5964: 'Lotso' from archive ''
MSG: ID 5965: 'SonicBoom' from archive ''
MSG: ID 5966: 'Duke' from archive ''
MSG: ID 5967: 'Kusanagi' from archive ''
MSG: ID 5968: 'The Amazing Spiderman' from archive ''
MSG: ID 5969: 'luffy' from archive ''
MSG: ID 5970: 'luffy' from archive ''
MSG: ID 5971: 'Goku' from archive ''
MSG: ID 5972: 'luffy' from archive ''
MSG: ID 5973: 'Carl Johnson' from archive ''
MSG: ID 5974: 'hitman' from archive ''
MSG: ID 5975: '47 hitman' from archive ''
MSG: ID 5976: 'luffy' from archive ''
MSG: ID 5977: 'Murder' from archive ''
MSG: ID 5978: 'Mario' from archive ''
MSG: ID 5979: 'Batman' from archive ''
MSG: ID 5980: 'Cloude' from archive ''
MSG: ID 5981: 'Leon s kennedy' from archive ''
MSG: ID 5982: 'Doc' from archive ''
MSG: ID 5983: 'WFOSH' from archive ''
MSG: ID 5984: 'Alien' from archive ''
MSG: ID 5985: 'Skeleton' from archive ''
MSG: ID 5986: 'Gordon Freeman' from archive ''
MSG: ID 5987: 'Alien' from archive ''
MSG: ID 5988: 'Donald Trump' from archive ''
MSG: ID 5989: 'Tigger' from archive ''
MSG: ID 5990: 'GunDam' from archive ''
MSG: ID 5991: 'Gordon Freeman' from archive ''
MSG: ID 5992: 'Zombie' from archive ''
MSG: ID 5993: 'Big foot' from archive ''
MSG: ID 5995: 'Hero Skin' from archive ''
Error in CSkinHandler::LoadSkinArchives: Could not load skin file 'skins/z299_hitman.7z' with model index 6049 - invalid model index.
Error in CSkinHandler::LoadSkinArchives: Could not load skin file 'skins/z300_cj.7z' with model index 6050 - invalid model index.
MSG: [MGUI] No UI skin found
MSG: Scripts initialised.



Please note that this is my testing server, it's not a public server so I got a lot of junk laying around that may or may not work.

Also there is no new info added when I test out the bug, it's only added when the server is being loaded.